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SliceAndDice

Got an image that you want to use for navigation on your web site?
Want to turn images directly into web pages? [SCREENSHOT]

In the past, web page designers would spend hours in PhotoShop,
carefully dividing images into smaller subimages, then creating an
HTML table to put the subimages back together, then editing the
HTML to add a URL to each subimage. (Here's an article on the
subject.)

SliceAndDice automates that process.

Simply drag in an image, drag on horizontal and vertical cut lines,
and drag on or type in URLs  for each subimage. SliceAndDice will
subdivide your image, create an HTML Table with the subimages
and links, and display the reassembled image in your web browser.

Add a second image and SliceAndDice will automatically write the
JavaScript to create rollovers that show the second image when
the user's mouse is over a subimage.

Substitute any image (including animated GIFs) for any of the
subimages.

Overview
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Features

SliceAndDice lets you easily:

• Divide images into subimages, each of which can have its own URL

• Create navigation bars and ersatz image maps

• Create JavaScript rollovers

• Replace subimages with other images, including animated GIFs.

• Drag and drop images and subimages

• Crop images

• Control the output image format: choose JPEG, GIF, TIFF, or PNG with
control over compression, interlace and dithering

• Edit the HTML produced by SliceAndDice because the output is
extremely readable

• Give each subimage a name or use SliceAndDice’s automatic and
convenient naming by row and column position.
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To get an overview of what SliceAndDice can do, choose
Samples->Freehand Bar. Then choose File -> Slice & Dice and type in a
new folder name. Your web browser will display the HTML file and images
created by SliceAndDice.

Now try it yourself...

Quick Start
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1. Open an image. Drag an image file into Slice & Dice's document
window or choose Samples -> Try This.

2. Divide the image by
dragging dividers from the
Horizontal and Vertical
Divider wells in the
document window.

Quick Start

Horizontal
Divider Well

Vertical
Divider
Well
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3. Optional: Group the subimages.

4. Optional: Add a second image that will be
displayed when the viewer's mouse rolls over
a subimage.

5. Add URLs and alternate text to the
subimages. Double-click on a subimage and
type in the URL and alternate text in the
Inspector Panel.

Quick Start

6. Create the subimage files and the HTML to reassemble the subimages.
Select File -> Slice & Dice and enter a folder name for the HTML and
subimages. Your web browser will open the HTML so you can see the
results. Use your browser's View Source command to copy the HTML to use
in your web pages.
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To open an image in SliceAndDice, you can:

Choose File -> Open Image... and select an image file in the Open Panel
(Slice & Dice can open TIFF, EPS, GIF, JPG, and PNG image formats)

If you don't already have an open document window, choose File -> New.
Then you can:

Drag and drop any image
onto the document window

Paste any image into the
document window

Slicing Your Image: Opening An Image
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The Document Tab on the Info window shows the size of the image and
the number of rows and columns that you have created by dividing your
image.

Slicing Your Image: Size Information
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If you only want part of your image to be displayed, you can crop your image
within SliceAndDice.

To crop your image, hold the Command key while you click and drag over
the image.

Slicing Your Image: Cropping

When you release the mouse button,
the portion of the image that you've
selected will be automatically copied
into the pasteboard. Also, your
selection will be outlined in a flashing
rectangle.
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You can paste the copied image into the original window (Command-v or
Edit->Paste). A dialog box will appear asking if you want to create a new
document or replace the existing image. 

If you replace the existing image, any previous slices
that you've made will remain.

Slicing Your Image: Cropping
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To divide an image:

Drag a "divider" from the Horizontal or Vertical Divider Well and drop it onto the
image. The image will be divided at that point.

Slicing Your Image: Dividing

Horizontal Divider
Well

Vertical
Divider
Well

Dividers can be repositioned and
removed.

To move a divider, click on the
divider and drag it to its new
location.

To remove a divider, click on
the divider and drag it off the
image.

Divider Palette

If the image is so small that
the Divider Wells are not
visible, a Divider Palette will
be displayed. Dividers can be
dragged onto your image from
the Divider Wells on the
palette.
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To select a subimage, click in it. The selected subimage will be clearly
indicated with blue rectangles.

When a single subimage is selected, the Sub
Image Tab of the Info window will show the
size of the subimage and its row and column
location.

Slicing Your Image: Selecting Subimages
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SliceAndDice

To select more than one subimage, you
can:

Click and drag out a selection.

Hold the shift key as you click on
unselected subimages.

To remove a subimage from the selection,
hold the shift key as you click on the
selected subimage.

To deselect all subimages, choose
Edit->Select None (Command-0).

Slicing Your Image: Selecting Multiple Subimages
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Groups allow you select any rectangular subset of subimages and combine
them into one larger subimage.

With groups, you can combine subimages that share the same URL and
minimize the number of subimages that are created.

Slicing Your Image: Grouping Subimages

To group subimages

1. Select the subimages you want to include in
the group.

2. Choose Edit->Group (Command-G). The
selected subimages must form a rectangle. If
they do not, the menu item Edit->Group will
not be available. 

Not a rectangle,
so the subimages
cannot be
grouped.

A rectangular
selection can be

grouped.
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If any of the selected subimages have a URL, that URL will be the group's URL.

If more than one selected subimage has a URL, the group's URL will be the URL
of the first subimage selected.

To ungroup a group of cells:

Select the group and choose Edit->Ungroup (Shift-Command-G).

If the group has a URL and/or Alternative Text, that information will be copied to
each of the subimages.

Slicing Your Image: Grouping Subimages

Not a rectangle,
so the subimages
cannot be
grouped.

A rectangular
selection can be
grouped.
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SliceAndDice

The Sub Image tab of
the Info window lets
you name
subimages, attach a
URL and alternate
text, and replace the
subimage with a
different image.

To bring up the
Subimage tab,
choose Tools -> Info
and click on the Sub
Image Tab.

Shortcut: Double-
clicking on a
subimage or group
both selects it and
brings up the
Subimage tab.

Slicing Your Image: Subimage Info
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SliceAndDice

You can give a name to each subimage. This will become the subimage's file
name and the name used in the HTML output. All non-alphanumeric
characters in the name will be replaced with underscores. For example, "The
Wizard's Head"  will become "The_Wizard_s_Head."

To name a subimage, select the subimage or group and type a name into the
Image Name field in the Sub Image tab. If more than one subimage is selected,
the Image Name field will be inactive.

Slicing Your Image: Naming Subimages
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SliceAndDice

You can add a URL to a subimage or group. SliceAndDice will add a link to that
subimage in the HTML so that when the viewer clicks on the subimage, the
viewer's browser will open the link.

To add a URL, select a subimage or group and type in the URL in the URL
field in the Sub Image tab of the Info window.

Shortcut: If you have a browser that supports URL drag and drop, you can
drag and drop a URL directly onto a subimage or group or onto the URL field.

Slicing Your Image: Adding URLs
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SliceAndDice

The Alternate Text field is for text that will be displayed in browsers that don't
support graphics or that have their graphics turned off. It is also displayed
before the image is loaded into the browser.

To add alternate text to a subimage, select the subimage or group and type
the text into the Alternate Text field in the Sub Image tab of the Info window.

If you dragged in a URL that included text, that text will appear in the Alternate
Text field.

Slicing Your Image: Alternative Text
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You can eliminate one or more subimages. If
you check "Use a spacer instead of image,"
SliceAndDice will generate HTML that
replaces the selected subimage with a
transparent image. This allows the page color
or background image to show.

Slicing Your Image: Using a Spacer
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SliceAndDice

You can replace one or more subimages with other images. You could use this
to replace part of an image with an altered image or even with an animated gif.
These images don't show up in SliceAndDice, but will be used in the
generated HTML files.

The replacement image will be
scaled to fit the size of the original
subimage.

To replace a subimage

1. Select the subimage.

2. Click on the Set button in the
Sub Image tab of the Info window.
Use the Open dialog to select the
image that you want to use as a
substitute image.

Shortcut: You can drag the
replacement image file icon onto
the replacement image text field.

Slicing Your Image: Using Alternative Images

<!-- Slice And Dice by
Stone Design:
www.stone.com -->
<TABLE BORDER=0
CELLPADDING=0
CELLSPACING=0
WIDTH=148>
   <TR VALIGN="top"
ALIGN="left">
      <td width=148
height=51 rowspan=1
colspan=3>
         <img
src="images/WizHeadSta
rs2_R_01_C_01.gif"
width=148 height=51
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SliceAndDice

Rollover images are images that appear in a browser only when the user's
mouse is over the image. They require a browser that supports JavaScript. You
can use SliceAndDice to quickly and easily create rollover images.

Slicing Your Image: Creating Rollovers

Note: The Apple Help Viewer does not support JavaScript, so the rollovers
will not appear.
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SliceAndDice

To create a rollover image:

1. Drag in or paste an image that's EXACTLY the same dimensions as the
current image.

2. Choose Rollover from the dialog that appears. If the new image is not
exactly the same size, you'll get the Replace/New Document dialog instead.

Slicing Your Image: Creating Rollovers

To switch between the Main image and the Rollover image, use the pop-
up menu next to the horizontal divider well.

You can add dividers to either image; all dividers will appear in both images
and will divide both images into subimages.
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SliceAndDice

You can set whether
the Rollover image will
be used for any given
subimage. The
Rollover image will be
used by default. If you
don't want the
Rollover subimage to
appear, bring up the
Info window
(Tools->Info
(Command-i)) and
choose the Rollover
Tab. Uncheck the
"Use the rollover in
this cell" Checkbox.

Slicing Your Image: Creating Rollovers
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SliceAndDice

You can replace a Rollover subimage with another image. To replace a
Rollover subimage, enter a substitute image file name in the Rollover tab of
the Info window. You can click on the Set... button or drag and drop a file
icon onto the text field.

This feature allows you, for example, to substitute an animated GIF for a
rollover subimage.

Slicing Your Image: Creating Rollovers
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SliceAndDice

You can save your sliced images as a Slice document. This document
contains the image, the slice locations, and the URL information.

To save the current document, choose File->Save. If this is the first time
you've saved this document, you'll use the Save dialog to select a location
and file name for the document.

Web Output: Saving Your Document

Make sure to select Slice Document from the File Format drop down menu. (A
Fully Sliced Document can be dropped into a Create document.) 

To save the current document with a different name, choose File->Save As.
Use the Save dialog to select a location and file name.

To open a previously saved Slice document, choose File->Open... or
double-click on the document's icon in the Workspace Manager.
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SliceAndDice

The Document tab of
the Info window lets
you control some
aspects of the HTML
generated by
SliceAndDice. To
display the Document
tab, choose Tools ->
Info (Command-i)
and then select the
Document Tab.

Web Output: Document Info



28 SliceAndDice Manual

Generating
Output
Saving /
Document
Inspector /
Subimage Format /
Background Color /
Note / Default / 
HREF /
Directory Structure

Overview
Features
Quick Start
Slicing Details
Web Output
Preferences
Installation
Licensing
Support

SliceAndDice

You can choose the file format of the subimage files. Your choices are: TIFF,
JPEG, GIF and PNG. JPEG and GIF are the most common, and JPEG gives
you the highest resolution.

With GIF, you can turn on dithering or
transparent values.

With PNG, you can choose to interlace
the image.  An interlaced image will
show itself in several separate passes,
with increasing resolution with each
pass. Contrast this to a JPEG, which
gets rendered from top to bottom in one
pass.

With TIFF and JPEG, you can set the
quality (related to the amount of
compression) using the slider. Slide the
slider to the right for high quality but
larger files. The default setting is a good
compromise between quality and file
size.

Web Output: Subimage Format
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SliceAndDice

The Background color well lets you select a background color for your image.
This color will appear behind the image if your original image is a GIF with
transparency. Notice that the background color selected in Slice & Dice does
not affect the background color of the overall HTML page.

Web Output: Background Color
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The note field lets you add a comment to the HTML output. Anything you type
into the note field will appear as a comment immediately before the HTML
Table code.

<!-- Slice And Dice by Stone Design: www.stone.com
-->
<!-- I can add a comment here. -->

Web Output: Adding a Note
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Restoring Defaults

The Default button will cause all settings to revert to the settings that you've
set in Preferences.

Stub Out HREF (Set in Preferences)

You may wish to add URLs to the subimages after the HTML is generated.
Slice & Dice makes this easy by providing the option to add an empty HREF
reference to each subimage. When you check this box, each image that
doesn't already have a specified URL will generate this tag: <A HREF="">.
You can easily hand-edit the HTML to add the URLs later.

To add HREF stubs to the HTML generated by Slice & Dice, choose
Edit->Preferences and check the "Stub out HREF if no URL" checkbox.

Web Output - Misc
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Output Directory Structure (Set in Preferences)

When SliceAndDice generates HTML and graphic files, it creates a new folder
with two items: an HTML document, <filename>.html and a folder named
"images" which contains all the images referenced in the HTML document. If
you wish, you can set your Preferences to place the image files in the same
folder with the HTML file.

Web Output - Output Directory Structure

Saved Folder Name

images
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When you've set the output options and preferences, choose File->Slice &
Dice. Enter a new folder name in the Save dialog. SliceAndDice will create the
directory, the HTML file, and the image files; it will then notify your browser to
open the HTML file so you can see the results.

How To Use SliceAndDice's Output

How you use the HTML and image files created by SliceAndDice depends on
the tools you use for building your web pages.

If you're hand-coding HTML, you can open the HTML file created by
SliceAndDice and copy and paste the HTML into your own document. If you've
used SliceAndDice's Rollover feature, you'll need to copy the JavaScript code
into your <HEAD> section. SliceAndDice creates a self-contained TABLE to
contain the image pieces; you can paste the table code into a table cell in your
own HTML. Of course, you'll need to make sure to move the subimage files to
the images folder in your page's folder.

If you’re using Stone Design’s Create®, choose File->Save For Create….
This makes a Fully Sliced document which you can drag and drop into a
Create document. When Create generates the HTML for the document, it will
generate the Table code, JavaScript code, and subimages for the sliced
image.

Generating HTML
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The settings in the Preferences panel affect all new SliceAndDice documents.
Settings for the output files can be changed for individual SliceAndDice
documents in the Document tab of the Info window. Settings for HREF stubs
and Output Directory Format can only be changed in the Preferences Panel.

The Return to Original Values button will return the Preferences settings to the
original "factory" settings.

Preferences
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SliceAndDice

You can order SliceAndDice licenses directly from inside the application by
choosing SliceAndDice->Purchase... You will be connected to our secure
web server at the Stone Design Web Site.

You can fax us PO's at: (USA) 505-345-3424.

You can send us cheques and money orders to:
!!!!Stone Design Corp
!!!!2400 Rio Grande Blvd NW pmb 116
!!!!Albuquerque, NM 87104
!!!!USA

You can just give us a call at (USA) 505-345-4800.

You can send email to us at orders@stone.com.

Technical Support: Ordering Licenses
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Installing SliceAndDice is easy:

If  you download SliceAndDice from
http://www.stone.com/NewDownload.html, you will have a
Disk Image file (.dmg). 

Double-click the image to mount it, and copy SliceAndDice
to your Applications folder.

From the Stone Design CD: simply drag SliceAndDice to
your applications folder.

Technical Support: Installation
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SliceAndDice

Contact Stone Design via bugs@stone.com for fast email support. The easiest
way to do this is simply choose Help -> Suggestion...  and you will be
connected to our feedback page on our web site.

Technical Support: Support
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SliceAndDice

Disclaimer:
Stone Design disclaims all warranties with regard to this software and
technology to the extent possible by federal law, including all implied
warranties of merchantability and fitness, in no event shall Stone Design be
liable for any special, indirect or consequential damages or any damages
whatsoever resulting from loss of use, data or profits, whether in an action of
contract, negligence or other tortious action, arising out of or in connection
with the use or performance of this software. 

Legal


